IEWebGL

Микрософт пока не собирается реализовывать WebGL в своём браузере, так как считает, что технология не устоялась (и даже называла её небезопасной). Для тех, кто почему-либо хочет пользоваться IE, но хочет попробовать WebGL, есть специальный плагин IEWebGL, недавно вышел релиз.

Плагин показывает отличную производительность (до 100 fps под IE9 и 10PP, до 60 — под IE8), работает начиная с IE6, не требует OpenGL и менять в HTML или JavaScript сайта так же ничего не требуется.
31 августа 2011 17:23

Александр Карпинский (инкогнито)
31 августа 2011, 21:53

показывает отличную производительность (100 fps под IE9 и 10PP, 80 — под IE8)
Ну во-первых на сайте сказано что под ие8 — 60, а не 80. Во-вторых — о чем речь? «Наш алгоритм делает 500 вычислений в секунду!». Какая сцена, на каком железе? Ничего не сказано. 100 fps, конечно, круто, но может они один треугольник крутили вокруг собственной оси?

bolk (bolknote.ru)
31 августа 2011, 22:21, ответ предназначен Александру Карпинскому

Ну во-первых на сайте сказано что под ие8 — 60
Поправил, спасибо!
Ничего не сказано. 100 fps, конечно, круто, но может они один треугольник крутили вокруг собственной оси?
Вполне может быть. Уже 10 fps для многого достаточно.

bolk (bolknote.ru)
31 августа 2011, 22:29, ответ предназначен Александру Карпинскому

Кстати, на сайте написано «до 100», исправил как на сайте, чтобы никого не смущать.

MOD (инкогнито)
12 сентября 2011, 19:11

Числа в 100 FPS / 60 FPS - это показатель низких накладных расходов браузера и плагина.
В реальных приложениях FPS разумеется зависит от сложности сцены производительности компьютера и других факторов.
Для разработчика, знать, что его приложение при должной оптимизации может работать теоретически со скоростью
60-100 FPS - приятно.

С уважением Моденов Иван.
Разработчик IEWebGL.

bolk (bolknote.ru)
13 сентября 2011, 12:16, ответ предназначен MOD

Спасибо вам, Иван, за проделанную работу!

Иван (инкогнито)
13 мая 2012, 21:58

Доброго времени суток!
Проблема следующая. Cкачал плагин IEWEBGL, а объекты все равно не открываются. C чем это может быть связано? Тестирую проект локально. Проверяю в firefox - все нормально отображается. IE 9 версия.
Что может быть не так?

bolk (bolknote.ru)
14 мая 2012, 21:45, ответ предназначен Ивану

Так задайте вопрос разработчикам!

Ваше имя или адрес блога (можно OpenID):

Текст вашего комментария, не HTML:

Кому бы вы хотели ответить (или кликните на его аватару)