Такое количество очевидных багов, как в Thunderbird 3 я не видел ещё ни в одном релизе какого-либо серьёзного продукта за последние годы. Двоящиеся сообщения в поиске, проблемы с отображением кодировок в списке писем (в просмотре письма всё нормально), кнопка «Reply» закрывает имя отправителя и так далее. Всё это видно уже через первые пять минут пользования продуктом. Через два дня работы их, наверное, можно найти все.
Комментарии 36
Ещё есть баг с плагином PGP (но это уже не относится к THB3) — неправильно показываются кодированные символы в from.
Thunderbird 3 вышел по принципу «чтобы не выпустить, только бы догнать платформу». Firefox 3 вышел когда? Вона.
Firefox 3.5 вышел летом. Firefox 3.6 буквально «уже вот». Поддержку ветки Mozilla 1.8.1 тащить на себе Thunderbird больше не мог, надо было релизиться срочно.
Кроме того, багов и должно быть много — они разрабатывались кучу лет без релиза (c 18 апреля 2007 года).
Что же они не тестируют что ли? Как это «должно быть много багов», если «кучу лет без релиза»?
Поиск хорош, и индексация тоже неплоха. Адресная книга и подсвечивание звездочками по месту — вроде бы тоже удобные. А вот, к примеру, reply to an email which you received as an attachment как был невозможен раньше, так и невозможен и сейчас.
А у меня gentoo, винды не видал. :)
У меня
Я вот вижу прямую связь между «кучу лет без релиза» и много багов.
Все это вылезает только при определенных условиях. Если ты release often, то у тебя все оно постоянно вылезает. А если нет — то твои 5 тестеров ходят по схожим конфигурациям, и у них все круто.
Для Thunderbird решающим будет 3.1 (или как они его назовут). Смогут одновременно:
а) устаканить стабильность до приемлимого уровня
б) «догнаться» до очередной платформы Mozilla (вероятно 1.9.2 ака 3.6)
в)
То у Thunderbird есть будущее. Нет — скоро загнется.
Комментарий для leotsarev.livejournal.com:
Они выпускали кучу бет. Я не понимаю почему никто не нашёл эти баги раньше. Ведь многие скачивали.
Были бы ещё альтернативы.
Потому что бету юзает чуть менее чем никто.
Я её себе ставил, сказал «AAAAAAAAAAAAAAA!!!!!!!!» и снёс. Зато беты браузеров ставлю регулярно.
А T3 устанавливался с нуля, или уже был профиль от T2 или от беты T3?
Windows
Сколько я не пробовал, глючит кодировка только в спамерских письмах, они вечно пишут в заголовках с нарушением MIME.
То есть известно — если написать письмо с восьмибитным текстом в заголовках, например, в From: или Subject:, то гарантированно получатся ??? в Thunderbird, в любом. Единственное, что их лечит — это указание кодировки по умолчанию в свойствах конкретной папки почты.
А пока я доволен, у меня вот так http://picasaweb.google.com.ua/jankkhvej/T … 1211668226 после автоматической миграции с TB2 на TB3.
Письмо на скриншоте не спамерское, это от магазина. Но с нарушением стандарта, да — subj не закодирован. Но что мешает брать кодировку в этом случае из письма я не понимаю.
«Но что мешает брать кодировку в этом случае из письма я не понимаю.» — именно стандарт и мешает. Нельзя в заголовках восьмибитные символы использовать.
Я совершенно случайно знаю какое количество писем ходит, оформленных не по стандарту. Почтовый клиент обязан их читать. Ведь
Так это… Указание кодировки на папке помогло или нет?
Нет.
а можно ссылку на конкретное место стандарта, где запрещается 8 бит в заголовках.
RFC2822, Status: PROPOSED STANDARD
http://tools.ietf.org/html/rfc2822#section-2.2
[…]
Header fields are lines composed of a field name, followed by a colon
(«:»), followed by a field body, and terminated by CRLF. A field
name MUST be composed of printable
characters that have values between 33 and 126, inclusive), except
colon. A field body may be composed of any
except for CR and LF. However, a field body may contain CRLF when
used in header «folding» and «unfolding» as described in section
2.2.3. All field bodies MUST conform to the syntax described in
sections 3 and 4 of this standard.
[…]
RFC5322, Status: DRAFT STANDARD — http://tools.ietf.org/html/rfc5322
RFC5335, Status: EXPERIMENTAL — http://tools.ietf.org/html/rfc5335
RFC5336, Status: EXPERIMENTAL — http://tools.ietf.org/html/rfc5336
And sorry me English, it's to indicate Ukrainian/Russian layout unavailability only, no insults are planned.